СохраненныеПараметрыБлокировки (БСП)

Автор: 1С
ОбщийМодуль.БлокировкаРаботыСВнешнимиРесурсами
БСП

Сохраненные параметры блокировки.

Функция СохраненныеПараметрыБлокировки() Экспорт 
	
	УстановитьПривилегированныйРежим(Истина);
	Сохраненные = Константы.ПараметрыБлокировкиРаботыСВнешнимиРесурсами.Получить().Получить();
	УстановитьПривилегированныйРежим(Ложь);
	
	Результат = ТекущиеПараметрыБлокировки();
	
	Если Сохраненные = Неопределено Тогда 
		СохранитьПараметрыБлокировки(Результат); // Автоматическая инициализация.
		Если ОбщегоНазначения.ИнформационнаяБазаФайловая() Тогда
			ЗаписатьИдентификаторФайловойБазыВФайлПроверки(Результат.ИдентификаторБазы);
		КонецЕсли;
	КонецЕсли;
	
	Если ТипЗнч(Сохраненные) = Тип("Структура") Тогда 
		ЗаполнитьЗначенияСвойств(Результат, Сохраненные); // Переинициализация новых свойств.
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СохраненныеПараметрыАдминистрирования (БСП)

ПараметрыБлокировкиСеансов (БСП)

ПриОпределенииПараметровБлокировкиСеансов (БСП)

ИнформацияОСохраненнойКомпоненте (БСП)

ПараметрыСохраненияФайла (БСП)

ПараметрыСохраненияФайлов (БСП)

ПараметрыРезервногоКопирования (БСП)

ПараметрыАдминистрирования (БСП)

TurboConf 6 - расширение Конфигуратора 1С