ВыполнитьПроцедуруМодуляОбъектаОбработки (БСП)

Автор: 1С
ОбщийМодуль.ДлительныеОперации
БСП

Выполнить процедуру модуля объекта обработки.

Процедура ВыполнитьПроцедуруМодуляОбъектаОбработки(Параметры, АдресХранилища) Экспорт 
	Если Параметры.ЭтоВнешняяОбработка Тогда
		Ссылка = ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(Параметры, "ДополнительнаяОбработкаСсылка");
		Если ЗначениеЗаполнено(Ссылка) И ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ДополнительныеОтчетыИОбработки") Тогда
			Обработка = ОбщегоНазначения.ОбщийМодуль("ДополнительныеОтчетыИОбработки").ОбъектВнешнейОбработки(Ссылка);
		Иначе
			ВыполнитьПроверкуПравДоступа("ИнтерактивноеОткрытиеВнешнихОбработок", Метаданные);
			Обработка = ВнешниеОбработки.Создать(Параметры.ИмяОбработки, БезопасныйРежим());
		КонецЕсли;
	Иначе
		Обработка = Обработки[Параметры.ИмяОбработки].Создать();
	КонецЕсли;
	
	ПараметрыМетода = Новый Массив;
	ПараметрыМетода.Добавить(Параметры.ПараметрыВыполнения);
	ПараметрыМетода.Добавить(АдресХранилища);
	ОбщегоНазначения.ВыполнитьМетодОбъекта(Обработка, Параметры.ИмяМетода, ПараметрыМетода);
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВыполнитьПроцедуруМодуляОбъектаОтчета (БСП)

Вызов процедур или функций модуля объекта из модуля формы

ВыполнитьМетодОбъекта (БСП)

Подключение внешней обработки/отчета, пример оформления модуля объекта

ПриДобавленииПереименованийОбъектовМетаданных (БСП)

ОпределитьОбъектыСКомандамиОтчетов (БСП)

ПриОпределенииОбъектовСКомандамиЗаполнения (БСП)

ПриОпределенииОбъектовСКомандамиПечати (БСП)

ВыполнитьКомандуИзФормыВнешнегоОбъекта (БСП)

TurboConf - расширение Конфигуратора 1С