ЗакрытьФормуДлительнойОперации (БСП)

Автор: 1С
ОбщийМодуль.ДлительныеОперацииКлиент
БСП

Закрыть форму длительной операции. Устарела. Следует использовать ОжидатьЗавершение с параметром ПараметрыОжидания.ВыводитьОкноОжидания = Истина.

// Устарела. Следует использовать ОжидатьЗавершение с параметром ПараметрыОжидания.ВыводитьОкноОжидания = Истина.
// Закрывает форму-индикатор длительной операции.
// 
// Параметры:
//  ФормаДлительнойОперации - ФормаКлиентскогоПриложения - ссылка на форму-индикатор длительной операции. 
//
Процедура ЗакрытьФормуДлительнойОперации(ФормаДлительнойОперации) Экспорт
	
	Если ТипЗнч(ФормаДлительнойОперации) = Тип("ФормаКлиентскогоПриложения") Тогда
		Если ФормаДлительнойОперации.Открыта() Тогда
			ФормаДлительнойОперации.Закрыть();
		КонецЕсли;
	КонецЕсли;
	ФормаДлительнойОперации = Неопределено;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИмяФормыДлительнойОперации (БСП)

КонтрольДлительныхОпераций (БСП)

АктивныеДлительныеОперации (БСП)

ЗапуститьДлительнуюОперацию (БСП)

ЗакончитьЗамерДлительнойОперации (БСП)

ОжидатьЗавершение (БСП)

ОткрытьФормуДлительнойОперации (БСП)

ДлительнаяОперацияСклоненияПоПадежам (БСП)

TurboConf - расширение Конфигуратора 1С