ЗагрузитьДополнительныеОтчетыИОбработкиИзМетаданных (БСП)

Автор: 1С
ОбщийМодуль.ДополнительныеОтчетыИОбработки
БСП

Загрузить дополнительные отчеты обработки из метаданных. Обновляет отчеты и обработки в справочнике из общих макетов.

// Обновляет отчеты и обработки в справочнике из общих макетов.
//
// Параметры:
//   ОтчетыИОбработки - ТаблицаЗначений - Таблица отчетов и обработок в общих макетах.
//       * ОбъектМетаданных - ОбъектМетаданных - Отчет или обработка из конфигурации.
//       * СтарыеИменаОбъектов - Массив - Старые имена объектов для поиска старых версий этого отчета или обработки.
//           ** Строка - Старое имя объекта.
//       * СтарыеИменаФайлов - Массив - Старые имена файлов для поиска старых версий этого отчета или обработки.
//           ** Строка - Старое имя файла.
//
Процедура ЗагрузитьДополнительныеОтчетыИОбработкиИзМетаданных(ОтчетыИОбработки) Экспорт
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьДополнительныеОтчетыИОбработки") Тогда
		Возврат;
	КонецЕсли;
	
	СопоставитьОбработкиКонфигурацииСОбработкамиСправочника(ОтчетыИОбработки);
	Если ОтчетыИОбработки.Количество() = 0 Тогда
		Возврат; // Обновление не требуется.
	КонецЕсли;
	
	ВыгрузитьОтчетыИОбработкиВФайлы(ОтчетыИОбработки);
	Если ОтчетыИОбработки.Количество() = 0 Тогда
		Возврат; // Выгрузка провалилась.
	КонецЕсли;
	
	ЗарегистрироватьОтчетыИОбработки(ОтчетыИОбработки);
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВидОбработкиДополнительныйОтчет (БСП)

ИспользуютсяДополнительныеОтчетыИОбработки (БСП)

ПриПодключенииОтчета (БСП)

ЗаблокироватьДополнительныеОтчетыИОбработкиДляОбновления (БСП)

ПриОпределенииОтчетовСНастройками (БСП)

ПриПодключенииДопОтчета (БСП)

ОбработкаДополнительнойРасшифровки (БСП)

СформироватьМанифест (БСП)

ФормаОтчетаОбработкаДополнительнойРасшифровки (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз