ДоступныеВидыПубликации (БСП)

Автор: 1С
ОбщийМодуль.ДополнительныеОтчетыИОбработкиПовтИсп
БСП

Доступные виды публикации. Виды публикации дополнительных обработок, доступные в программе.

// Виды публикации дополнительных обработок, доступные в программе.
Функция ДоступныеВидыПубликации() Экспорт
	
	Результат = Новый Массив();
	
	Значения = Метаданные.Перечисления.ВариантыПубликацииДополнительныхОтчетовИОбработок.ЗначенияПеречисления;
	ИсключаемыеВидыПубликации = ДополнительныеОтчетыИОбработки.НедоступныеВидыПубликации();
	
	Для Каждого Значение Из Значения Цикл
		Если ИсключаемыеВидыПубликации.Найти(Значение.Имя) = Неопределено Тогда
			Результат.Добавить(Перечисления.ВариантыПубликацииДополнительныхОтчетовИОбработок[Значение.Имя]);
		КонецЕсли;
	КонецЦикла;
	
	Возврат Новый ФиксированныйМассив(Результат);
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НедоступныеВидыПубликации (БСП)

ПриЗаполненииНедоступныхВидовПубликации (БСП)

ПроверитьДоступностьКомпонентыПослеОтображенияДоступныхВидовКлиентов (БСП)

СписокДоступныхПоисков (БСП)

ЗаполнитьСписокВыбораДоступнымиВидамиТранспорта (БСП)

НовоеОписаниеСсылкиСайтаДляПубликацииПриложенийЧерезИнтернет (БСП)

АдресПубликацииИнформационнойБазыВИнтернете (БСП)

TurboConf - расширение Конфигуратора 1С