ПриПолученииРегистрационныхДанных (БСП)

Автор: 1С
ОбщийМодуль.ДополнительныеОтчетыИОбработкиВМоделиСервиса
БСП

При получении регистрационных данных. Вызывается при получении регистрационных данных для нового дополнительного отчета

// Вызывается при получении регистрационных данных для нового дополнительного отчета
// или обработки.
//
Процедура ПриПолученииРегистрационныхДанных(Объект, РегистрационныеДанные, СтандартнаяОбработка) Экспорт
	
	УстановитьПривилегированныйРежим(Истина);
	
	Если Не Объект.ЭтоНовый() И ОбщегоНазначения.РазделениеВключено() Тогда
		
		ПоставляемаяОбработка = ПоставляемаяОбработка(Объект.Ссылка);
		Если ЗначениеЗаполнено(ПоставляемаяОбработка) Тогда
			
			РегистрационныеДанные = ПолучитьРегистрационныеДанные(ПоставляемаяОбработка);
			СтандартнаяОбработка = Ложь;
			
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриПолученииРегистрационныхДанных (БСП)

ПриОпределенииРегистрационныхДанныхОрганизации (БСП)

РегистрационныеДанныеОрганизации (БСП)

РегистрационныеДанныеИндивидуальногоПредпринимателя (БСП)

ПриОпределенииРегистрационныхДанныхОбособленногоПодразделения (БСП)

ПриОпределенииРегистрационныхДанныхУполномоченногоПредставителя (БСП)

ПриОпределенииРегистрационныхДанныхИностраннойОрганизации (БСП)

ПриОпределенииРегистрационныхДанныхИндивидуальногоПредпринимателя (БСП)

ПриОпределенииРегистрационныхДанныхРуководителяОрганизации (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз