СинхронизацияЗначенийРегулирующихКонстант (БСП)

Автор: 1С
ОбщийМодуль.ДополнительныеОтчетыИОбработкиВМоделиСервиса
БСП

Синхронизация значений регулирующих констант. Процедура предназначена для синхронизации значений констант, регулирующих

// Процедура предназначена для синхронизации значений констант, регулирующих
//  использование дополнительных отчетов и обработок в модели сервиса. Процедура
//  должна вызываться при любом изменении любой из констант, регулирующих
//  использование дополнительных отчетов и обработок.
//
// Параметры:
//  Константа - строка, имя измененной константы, как оно задано в метаданных,
//  Значение - булево, новое значение измененной константы.
//
Процедура СинхронизацияЗначенийРегулирующихКонстант(Знач Константа, Знач Значение) Экспорт
	
	СостояниеИспользования = Ложь;
	
	РегулирующиеКонстанты = ДополнительныеОтчетыИОбработкиВМоделиСервисаПовтИсп.РегулирующиеКонстанты();
	
	Для Каждого РегулирующаяКонстанта Из РегулирующиеКонстанты Цикл
		
		Если РегулирующаяКонстанта = Константа Тогда
			ЗначениеКонстанты = Значение;
		Иначе
			ЗначениеКонстанты = Константы[РегулирующаяКонстанта].Получить();
		КонецЕсли;
		
		Если ЗначениеКонстанты Тогда
			СостояниеИспользования = Истина;
		КонецЕсли;
		
	КонецЦикла;
	
	Константы.ИспользоватьДополнительныеОтчетыИОбработки.Установить(СостояниеИспользования);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

РегулирующиеКонстанты (БСП)

ПриОтключенииСинхронизацииДанных (БСП)

УстановитьКонстантуНеИспользоватьРазделениеПоОбластямДанных (БСП)

СброситьЗначениеКонстантыСИзменениямиДляПодчиненногоУзлаРИБСФильтрами (БСП)

ПарольСинхронизацииДанных (БСП)

УстановитьВариантОбновленияКлассификаторов (БСП)

УстановитьФайлКлассификаторов (БСП)

ИспользоватьКонтрольТарификации (БСП)

ОбновитьИспользованиеКонтроляТарификации (БСП)

TurboConf - расширение Конфигуратора 1С