ПоместитьВХранилище (БСП)

Автор: 1С
ОбщийМодуль.ДополнительныеОтчетыИОбработкиВызовСервера
БСП

Поместить хранилище. Помещает двоичные данные дополнительного отчета или обработки во временное хранилище.

// Помещает двоичные данные дополнительного отчета или обработки во временное хранилище.
Функция ПоместитьВХранилище(Ссылка, ИдентификаторФормы) Экспорт
	Если ТипЗнч(Ссылка) <> Тип("СправочникСсылка.ДополнительныеОтчетыИОбработки") 
		Или Ссылка = Справочники.ДополнительныеОтчетыИОбработки.ПустаяСсылка() Тогда
		Возврат Неопределено;
	КонецЕсли;
	Если НЕ ДополнительныеОтчетыИОбработки.ВозможнаВыгрузкаОбработкиВФайл(Ссылка) Тогда
		ВызватьИсключение НСтр("ru = 'Недостаточно прав для выгрузки файлов дополнительных отчетов и обработок'");
	КонецЕсли;
	
	ХранилищеОбработки = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Ссылка, "ХранилищеОбработки");
	
	Возврат ПоместитьВоВременноеХранилище(ХранилищеОбработки.Получить(), ИдентификаторФормы);
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПоместитьФайлВХранилище (БСП)

ПоместитьФайлыВоВременноеХранилище (БСП)

ПоместитьФайлВХранилищеМенеджераСервиса (БСП)

ПоместитьДанныеВоВременноеХранилище (БСП)

ПоместитьПрисоединенныйФайл (БСП)

ПоместитьВыбранныеФайлыВХранилищеВебЗавершение (БСП)

ПоместитьМанифестКонфигурацииВоВременноеХранилище (БСП)

ПоместитьСообщениеДляСопоставленияДанных (БСП)

ПолеХранилище (БСП)

TurboConf - расширение Конфигуратора 1С