ПослеПодключенияКомпоненты (БСП)

Автор: 1С
ОбщийМодуль.ЭлектроннаяПодписьСлужебныйКлиент
БСП

После подключения компоненты.

Процедура ПослеПодключенияКомпоненты(Результат, Контекст) Экспорт
	
	Если Результат.Подключено Тогда
		Контекст.Вставить("ОбъектКомпоненты", Результат.ПодключаемыйМодуль);
		Контекст.МенеджерКриптографии.НачатьПолучениеИнформацииМодуляКриптографии(
			Новый ОписаниеОповещения("ПослеПолученияИнформацииМодуляКриптографии", ЭтотОбъект, Контекст));
	Иначе
		
		Если ПустаяСтрока(Результат.ОписаниеОшибки) Тогда 
			
			// Пользователь отказался от установки.
			
			ЗавершитьОперациюСОшибкой(
				Контекст,
				НСтр("ru = 'Операция невозможна. Требуется установка компоненты для HTTP-запросов.'"));
				
		Иначе 
			
			// Установка не удалась, описание ошибки в Результат.ОписаниеОшибки.
			
			ЗавершитьОперациюСОшибкой(
				Контекст,
				СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
					НСтр("ru = 'Операция невозможна. %1'"), Результат.ОписаниеОшибки));
			
		КонецЕсли;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПодключитьКомпонентуПослеПопыткиПодключения (БСП)

ПодключитьКомпонентуИзРеестраWindowsПослеПопыткиПодключения (БСП)

ЗагрузитьКомпонентуИзФайлаПослеЗагрузкиКомпоненты (БСП)

ПроверитьДоступностьКомпонентыПослеПоискаКомпонентыНаПортале (БСП)

ПодключитьКомпонентуОповеститьОПодключении (БСП)

ПодключитьКомпонентуПослеПроверкиДоступности (БСП)

УстановитьКомпонентуПослеПроверкиДоступности (БСП)

ПараметрыПодключенияКомпоненты (БСП)

ПослеПодключенияИнтернетПоддержки (БСП)

TurboConf - расширение Конфигуратора 1С