ПроверитьСертификатПослеСозданияМенеджераКриптографии (БСП)

Автор: 1С
ОбщийМодуль.ЭлектроннаяПодписьСлужебныйКлиент
БСП

Проверить сертификат после создания менеджера криптографии. Продолжение процедуры ПроверитьСертификат.

// Продолжение процедуры ПроверитьСертификат.
Процедура ПроверитьСертификатПослеСозданияМенеджераКриптографии(Результат, Контекст) Экспорт
	
	Если ТипЗнч(Результат) <> Тип("МенеджерКриптографии") Тогда
		ВыполнитьОбработкуОповещения(Контекст.Оповещение, Контекст.ОписаниеОшибкиНаСервере);
		Возврат;
	КонецЕсли;
	
	Контекст.МенеджерКриптографии = Результат;
	
	СертификатДляПроверки = Контекст.Сертификат;
	
	Если ТипЗнч(СертификатДляПроверки) = Тип("Строка") Тогда
		СертификатДляПроверки = ПолучитьИзВременногоХранилища(СертификатДляПроверки);
	КонецЕсли;
	
	Если ТипЗнч(СертификатДляПроверки) = Тип("ДвоичныеДанные") Тогда
		СертификатКриптографии = Новый СертификатКриптографии;
		СертификатКриптографии.НачатьИнициализацию(Новый ОписаниеОповещения(
				"ПроверитьСертификатПослеИнициализацииСертификата", ЭтотОбъект, Контекст),
			СертификатДляПроверки);
	Иначе
		ПроверитьСертификатПослеИнициализацииСертификата(СертификатДляПроверки, Контекст)
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьСертификатПоОтпечаткуПослеСозданияМенеджераКриптографии (БСП)

ПолучитьСвойстваСертификатовНаКлиентеПослеСозданияМенеджераКриптографии (БСП)

ПолучитьОтпечаткиСертификатовНаКлиентеПослеСозданияМенеджераКриптографии (БСП)

ПроверитьПодписиПослеСозданияМенеджераКриптографии (БСП)

ПроверитьПодписьПослеСозданияМенеджераКриптографии (БСП)

ДобавитьПодписьИзФайлаПослеСозданияМенеджераКриптографии (БСП)

ПродолжитьОткрытиеНачалоПослеСозданияМенеджераКриптографии (БСП)

ВыполнитьНаСторонеПослеСозданияМенеджераКриптографии (БСП)

ПроверитьСертификат (БСП)

TurboConf ИР адаптер 1.63