НомерКартинкиПоВзаимодействию (БСП)

Автор: 1С
ОбщийМодуль.ИнформационныйЦентрСервер
БСП

Номер картинки по взаимодействию. Номер картинки по типу взаимодействия.

// Номер картинки по типу взаимодействия.
//
// Параметры:
//	ТипВзаимодействия - Строка - тип взаимодействия.
//	Входящее - Булево - является ли взаимодействие входящим для пользователя.
//
// Возвращаемое значение:
//	Число - номер картинки.
//
Функция НомерКартинкиПоВзаимодействию(ТипВзаимодействия, Входящее) Экспорт
	
	Если ТипВзаимодействия = "Email" Тогда 
		Если Входящее Тогда 
			Возврат 2;
		Иначе
			Возврат 3;
		КонецЕсли;
	ИначеЕсли ТипВзаимодействия = "Comment" Тогда 
		Возврат 4;
	ИначеЕсли ТипВзаимодействия = "PhoneCall" Тогда 
		Возврат 1;
	КонецЕсли;
	
	Возврат 0;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НомераКартинокСобытий152ФЗ (БСП)

ВставитьКартинкиВHTML (БСП)

КартинкаСтраницыПодписи (БСП)

КартинкаПоСостояниюОбращения (БСП)

КартинкаКомментария (БСП)

ИндексКартинки (БСП)

ТемаВзаимодействия (БСП)

КонтактыВзаимодействий (БСП)

ПредметыВзаимодействий (БСП)

TurboConf - расширение Конфигуратора 1С