Показать (БСП)

Автор: 1С
ОбщийМодуль.ИнформацияПриЗапускеКлиент
БСП

Показать. Вызывается из обработчика ожидания, открывает окно информации.

// Вызывается из обработчика ожидания, открывает окно информации.
Процедура Показать() Экспорт
	
	Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("СтандартныеПодсистемы.ОценкаПроизводительности") Тогда
		МодульОценкаПроизводительностиКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("ОценкаПроизводительностиКлиент");
		МодульОценкаПроизводительностиКлиент.ЗамерВремени("ВремяОткрытияИнформацииПриЗапуске");
	КонецЕсли;
	
	Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("ИнтернетПоддержкаПользователей.Реклама") Тогда
		МодульРаботаСРекламойКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("РаботаСРекламойКлиент");
		МодульРаботаСРекламойКлиент.Показать();
	Иначе
		ОткрытьФорму("Обработка.ИнформацияПриЗапуске.Форма");
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПоказатьОповещение (БСП)

ПоказатьПодключение (БСП)

ПоказатьОтключение (БСП)

ПоказатьКлассификатор (БСП)

ПоказатьВопросПользователю (БСП)

ПоказатьПодтверждениеЗакрытияФормы (БСП)

ПоказатьФормуРедактированияМногострочногоТекста (БСП)

ПоказатьПредупреждениеМонопольногоРежимаИзменения (БСП)

ПоказатьПодтверждениеЗакрытияФормыСФайлами (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз