ДобавитьОбъектКОтправке (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияОбъектовОбластейДанных
БСП

Добавить объект отправке. Добавляет объект к отправке во внешнюю учетную систему.

// Добавляет объект к отправке во внешнюю учетную систему.
//
// Параметры:
//  УчетнаяСистема - ОпределяемыйТип.УчетныеСистемыИнтеграцииОбластейДанных - учетная система.
//  ИдентификаторОбъекта - Строка(50) - идентификатор объекта, должен соответствовать 
//                         требованиям к именованию файлов операционной системы.  
//  Обработчик - Строка(50) - идентификатор обработчика объекта.
//  ДанныеОбъекта - ДвоичныеДанные - данные объекта к отправке (если не указано, данные будут запрошены перед отправкой).
//
Процедура ДобавитьОбъектКОтправке(УчетнаяСистема, ИдентификаторОбъекта, Обработчик, ДанныеОбъекта = Неопределено) Экспорт
    
    ПривилегированныйРежимПриВызове = ПривилегированныйРежим();
    Если Не ПривилегированныйРежимПриВызове Тогда
        УстановитьОтключениеБезопасногоРежима(Истина);
        УстановитьПривилегированныйРежим(Истина);
    КонецЕсли;
    
    ИдентификаторФайла = Неопределено;
    Если ЗначениеЗаполнено(ДанныеОбъекта) Тогда
        ИдентификаторФайла = ФайлыОбластейДанных.ЗагрузитьФайл(ИдентификаторОбъекта, ДанныеОбъекта);
    КонецЕсли; 
    
    ЗарегистрироватьОтправку(УчетнаяСистема, ИдентификаторОбъекта, Обработчик, ИдентификаторФайла);
    
    Если Не ПривилегированныйРежимПриВызове Тогда
    	УстановитьПривилегированныйРежим(Ложь);
    	УстановитьОтключениеБезопасногоРежима(Ложь);
    КонецЕсли;
    
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ДобавитьВПараметрАдресатов (БСП)

УдалитьОбъектКОтправке (БСП)

ДобавитьОшибкуПользователю (БСП)

ДобавитьПодпись (БСП)

ДобавитьСертификатыШифрования (БСП)

ДобавитьОбъектВФильтрРазрешенныхОбъектов (БСП)

Добавить (БСП)

ДобавитьПереименование (БСП)

TurboConf - расширение Конфигуратора 1С