УдалитьОбъектКОтправке (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияОбъектовОбластейДанных
БСП

Удалить объект отправке. Удаляет объект из объектов к отправке в учетную систему.

// Удаляет объект из объектов к отправке в учетную систему.
//
// Параметры:
//  УчетнаяСистема - ОпределяемыйТип.УчетныеСистемыИнтеграцииОбластейДанных - учетная система.
//  ИдентификаторОбъекта - Строка(50) - идентификатор объекта
//  Обработчик - Строка(50) - идентификатор обработчика объекта.
//
Процедура УдалитьОбъектКОтправке(УчетнаяСистема, ИдентификаторОбъекта = Неопределено, Обработчик = Неопределено) Экспорт
    
    ПривилегированныйРежимПриВызове = ПривилегированныйРежим();
    Если Не ПривилегированныйРежимПриВызове Тогда
        УстановитьОтключениеБезопасногоРежима(Истина);
        УстановитьПривилегированныйРежим(Истина);
    КонецЕсли;
    
    Отбор = Новый Структура;
    Отбор.Вставить("УчетнаяСистема", УчетнаяСистема);
    Отбор.Вставить("ИдентификаторОбъекта", ИдентификаторОбъекта);
    Отбор.Вставить("Обработчик", Обработчик);
    
    РегистрыСведений.ОбъектыКОтправке.УдалитьЗаписи(Отбор);
	
    Если Не ПривилегированныйРежимПриВызове Тогда
    	УстановитьПривилегированныйРежим(Ложь);
    	УстановитьОтключениеБезопасногоРежима(Ложь);
    КонецЕсли;
    
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УдалитьВременныеОбъектыСозданныеПоСсылкам (БСП)

УдалитьДанные (БСП)

ДобавитьОбъектКОтправке (БСП)

Удалить префикс объекта и лидирующие нули (ЗУП 3)

УдалитьПодпись (БСП)

УдалитьЛидирующиеНулиИзНомераОбъекта (БСП)

УдалитьПользовательскиеПрефиксыИзНомераОбъекта (БСП)

УдалитьПрефиксыИзНомераОбъекта (БСП)

Удалить элемент массива

TurboConf - расширение Конфигуратора 1С