ИнтернетПоддержкаИСервисы_ОбработкаОповещения (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБИПКлиент
БСП

Интернет поддержка сервисы обработка оповещения. Выполняет обработку оповещения на панели администрирования

// Выполняет обработку оповещения на панели администрирования
// "Интернет-поддержка и сервисы" (БСП).
//
// Параметры:
//	Форма - ФормаКлиентскогоПриложения - форма, в которой обрабатывается оповещение;
//	ИмяСобытия - Строка - имя события;
//	Параметр - Произвольный - параметр;
//	Источник - Произвольный - источник события.
//
Процедура ИнтернетПоддержкаИСервисы_ОбработкаОповещения(Форма, ИмяСобытия, Параметр, Источник) Экспорт
	
	Если ИмяСобытия = "ИнтернетПоддержкаПодключена" Тогда
		
		// Обработка подключения Интернет-поддержки.
		ВведенныеДанныеАутентификации = Параметр;
		Если ВведенныеДанныеАутентификации <> Неопределено Тогда
			Форма.БИПДанныеАутентификации = ВведенныеДанныеАутентификации;
			ИнтернетПоддержкаПользователейКлиентСервер.ОтобразитьСостояниеПодключенияИПП(Форма);
		КонецЕсли;
	КонецЕсли;
	
	Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("ИнтернетПоддержкаПользователей.РаботаСКлассификаторами") Тогда
		МодульРаботаСКлассификаторамиКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("РаботаСКлассификаторамиКлиент");
		МодульРаботаСКлассификаторамиКлиент.ИнтернетПоддержкаИСервисы_ОбработкаОповещения(
			Форма,
			ИмяСобытия,
			Параметр,
			Источник);
	КонецЕсли;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИнтернетПоддержкаИСервисыПриСозданииНаСервере (БСП)

ИнтернетПоддержкаИСервисы_ДекорацияОбработкаНавигационнойСсылки (БСП)

ПодключитьИнтернетПоддержкуПользователей (БСП)

ИнтернетПоддержкаИСервисы_СообщениеВСлужбуТехническойПоддержки (БСП)

ИнтернетПоддержкаИСервисы_БИПДекорацияОбновлениеКлассификаторовНеВыполняетсяОбработкаНавигационнойСсылки (БСП)

ИнтернетПоддержкаИСервисы_БИПВойтиИлиВыйти (БСП)

ИнтернетПоддержкаИСервисы_ОбновлениеКлассификаторов (БСП)

ИнтернетПоддержкаИСервисы_ПриСозданииНаСервере (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз