ПередДобавлениемКомандПечати (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

Перед добавлением команд печати. См. УправлениеПечатьюПереопределяемый.ПередДобавлениемКомандПечати.

// См. УправлениеПечатьюПереопределяемый.ПередДобавлениемКомандПечати.
Процедура ПередДобавлениемКомандПечати(ИмяФормы, КомандыПечати, СтандартнаяОбработка) Экспорт
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБТС().ПередДобавлениемКомандПечати Тогда
		МодульИнтеграцияПодсистемБТС = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБТС");
		МодульИнтеграцияПодсистемБТС.ПередДобавлениемКомандПечати(ИмяФормы, КомандыПечати, СтандартнаяОбработка);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБИП().ПередДобавлениемКомандПечати Тогда
		МодульИнтеграцияПодсистемБИП = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБИП");
		МодульИнтеграцияПодсистемБИП.ПередДобавлениемКомандПечати(ИмяФормы, КомандыПечати, СтандартнаяОбработка);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередДобавлениемКомандПечати (БСП)

ПередДобавлениемКомандЗаполнения (БСП)

ПередВыполнениемКомандыПечатиВнешнейПечатнойФормы (БСП)

ПередДобавлениемКомандОтчетов (БСП)

КомандыПечатиОбъекта (БСП)

ВыполнитьНазначаемуюКомандуПечати (БСП)

ОтключитьКомандыПечати (БСП)

КомандыПечатиОбъектаДоступныеДляВложений (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз