ПередУдалениемПользователяИБ (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

Перед удалением пользователя. Вызывается перед удалением пользователя информационной базы.

// Вызывается перед удалением пользователя информационной базы.
//
// Параметры:
//  ПользовательИБ - ПользовательИнформационнойБазы - пользователь, который будет удален.
//
Процедура ПередУдалениемПользователяИБ(ПользовательИБ) Экспорт
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБТС().ПередУдалениемПользователяИБ Тогда
		МодульИнтеграцияПодсистемБТС = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБТС");
		МодульИнтеграцияПодсистемБТС.ПередУдалениемПользователяИБ(ПользовательИБ);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБИП().ПередУдалениемПользователяИБ Тогда
		МодульИнтеграцияПодсистемБИП = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБИП");
		МодульИнтеграцияПодсистемБИП.ПередУдалениемПользователяИБ(ПользовательИБ);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриУдаленииПользователя (БСП)

ПередУдалениемИдентификатораОбъектаМетаданных (БСП)

ПередПоискомПомеченныхНаУдаление (БСП)

ПриУдаленииПрочихНастроекПользователя (БСП)

ЗапретитьУдалениеПредопределенныхЭлементовПередУдалением (БСП)

ПередУдалениемПрисоединенногоФайлаСервер (БСП)

ПроверитьДатуЗапретаИзмененияПередУдалением (БСП)

ПередУдалениемОбъекта (БСП)

TurboConf - расширение Конфигуратора 1С