ПередЗагрузкойДанных (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

Перед загрузкой данных. См. ВыгрузкаЗагрузкаДанныхПереопределяемый.ПередЗагрузкойДанных

// См. ВыгрузкаЗагрузкаДанныхПереопределяемый.ПередЗагрузкойДанных
Процедура ПередЗагрузкойДанных(Контейнер) Экспорт
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.РаботаВМоделиСервиса.ОбновлениеВерсииИБВМоделиСервиса") Тогда
		МодульОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса = ОбщегоНазначения.ОбщийМодуль("ОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса");
		МодульОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса.ПередЗагрузкойДанных(Контейнер);
	КонецЕсли;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ИнтерфейсOData") Тогда
		МодульИнтерфейсODataСлужебный = ОбщегоНазначения.ОбщийМодуль("ИнтерфейсODataСлужебный");
		МодульИнтерфейсODataСлужебный.ПередЗагрузкойДанных(Контейнер);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПередЗагрузкойДанных (БСП)

ПередЗагрузкойФайлаОбменаДанными (БСП)

ПередЗагрузкойТипа (БСП)

ПередЗагрузкойПриоритетныхДанныхВПодчиненномРИБУзле (БСП)

УстановитьРежимЗагрузкиСообщенияОбменаДаннымиПередЗапуском (БСП)

TurboConf - расширение Конфигуратора 1С