ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

После изменения объекта авторизации внешнего пользователя. Доопределяет действия, необходимые после изменении объекта авторизации внешнего пользователя.

// Доопределяет действия, необходимые после изменении объекта авторизации внешнего пользователя.
// 
// Параметры:
//  ВнешнийПользователь     - СправочникСсылка.ВнешниеПользователи - внешний пользователь.
//  СтарыйОбъектАвторизации - NULL - при добавлении внешнего пользователя.
//                          - ОпределяемыйТип.ВнешнийПользователь - тип объекта авторизации.
//  НовыйОбъектАвторизации  - ОпределяемыйТип.ВнешнийПользователь - тип объекта авторизации.
//
Процедура ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя(ВнешнийПользователь,
                                                               СтарыйОбъектАвторизации,
                                                               НовыйОбъектАвторизации) Экспорт
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.УправлениеДоступом") Тогда
		МодульУправлениеДоступомСлужебный = ОбщегоНазначения.ОбщийМодуль("УправлениеДоступомСлужебный");
		МодульУправлениеДоступомСлужебный.ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя(
			ВнешнийПользователь, СтарыйОбъектАвторизации, НовыйОбъектАвторизации);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБТС().ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя Тогда
		МодульИнтеграцияПодсистемБТС = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБТС");
		МодульИнтеграцияПодсистемБТС.ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя(
			ВнешнийПользователь, СтарыйОбъектАвторизации, НовыйОбъектАвторизации);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБИП().ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя Тогда
		МодульИнтеграцияПодсистемБИП = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБИП");
		МодульИнтеграцияПодсистемБИП.ПослеИзмененияОбъектаАвторизацииВнешнегоПользователя(ВнешнийПользователь, СтарыйОбъектАвторизации, НовыйОбъектАвторизации);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьОбъектАвторизацииВнешнегоПользователя (БСП)

ПослеЗаписиАдминистратораПриАвторизации (БСП)

ОбновитьПредставлениеВнешнегоПользователяПриЗаписи (БСП)

ИнтерактивнаяОбработкаПриОшибкеАвторизации (БСП)

ПослеИзмененияПользователяИлиГруппыВФорме (БСП)

ПослеИзмененияПользователяИлиГруппыПользователейВФорме (БСП)

ПриАвторизацииНовогоПользователяИБ (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз