ПриДобавленииКлассификаторов (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

При добавлении классификаторов. См. РаботаСКлассификаторамиПереопределяемый.ПриДобавленииКлассификаторов.

// См. РаботаСКлассификаторамиПереопределяемый.ПриДобавленииКлассификаторов.
//
Процедура ПриДобавленииКлассификаторов(Классификаторы) Экспорт
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.Банки") Тогда
		МодульЗагрузкаКлассификатораБанков = ОбщегоНазначения.ОбщийМодуль("Обработки.ЗагрузкаКлассификатораБанков");
		МодульРаботаСКлассификаторами = ОбщегоНазначения.ОбщийМодуль("РаботаСКлассификаторами");
		МодульЗагрузкаКлассификатораБанков.ПриДобавленииКлассификаторов(Классификаторы, МодульРаботаСКлассификаторами.ОписаниеКлассификатора());
	КонецЕсли;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.Валюты") Тогда
		МодульЗагрузкаКурсовВалют = ОбщегоНазначения.ОбщийМодуль("Обработки.ЗагрузкаКурсовВалют");
		МодульРаботаСКлассификаторами = ОбщегоНазначения.ОбщийМодуль("РаботаСКлассификаторами");
		МодульЗагрузкаКурсовВалют.ПриДобавленииКлассификаторов(Классификаторы, МодульРаботаСКлассификаторами.ОписаниеКлассификатора());
	КонецЕсли;
		
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.КалендарныеГрафики") Тогда
		МодульКалендарныеГрафики = ОбщегоНазначения.ОбщийМодуль("КалендарныеГрафики");
		МодульКалендарныеГрафики.ПриДобавленииКлассификаторов(Классификаторы);
	КонецЕсли;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.КонтактнаяИнформация") 
		И Метаданные.ОбщиеМодули.Найти("РаботаСАдресами") <> Неопределено Тогда
			МодульРаботаСАдресами = ОбщегоНазначения.ОбщийМодуль("РаботаСАдресами");
			МодульРаботаСКлассификаторами = ОбщегоНазначения.ОбщийМодуль("РаботаСКлассификаторами");
			МодульРаботаСАдресами.ПриДобавленииКлассификаторов(Классификаторы, МодульРаботаСКлассификаторами.ОписаниеКлассификатора());
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриДобавленииКлассификаторов (БСП)

ПоказатьКлассификатор (БСП)

ДоступныеОбновленияКлассификаторов (БСП)

ПолучитьФайлыКлассификаторов (БСП)

СлужебнаяДоступныеОбновленияКлассификаторов (БСП)

ЗагрузитьАдресныйКлассификатор (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз