ПриОбработкеОбластиДанных (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

При обработке области данных. См. РаботаСКлассификаторамиВМоделиСервисаПереопределяемый.ПриОбработкеОбластиДанных.

// См. РаботаСКлассификаторамиВМоделиСервисаПереопределяемый.ПриОбработкеОбластиДанных.
Процедура ПриОбработкеОбластиДанных(Идентификатор, Версия, ДополнительныеПараметры) Экспорт
	
	Если Не ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.КалендарныеГрафики") Тогда
		Возврат;
	КонецЕсли;
	
	МодульКалендарныеГрафики = ОбщегоНазначения.ОбщийМодуль("КалендарныеГрафики");
	Если Идентификатор <> МодульКалендарныеГрафики.ИдентификаторКлассификатора() Тогда
		Возврат;
	КонецЕсли;

	Если Не ДополнительныеПараметры.Свойство(Идентификатор) Тогда
		Возврат;
	КонецЕсли;
	
	ПараметрыОбновления = ДополнительныеПараметры[Идентификатор];
	
	МодульКалендарныеГрафики.ЗаполнитьДанныеЗависимыеОтПроизводственныхКалендарей(ПараметрыОбновления.ТаблицаИзменений);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриОбработкеОбластиДанных (БСП)

ОбработатьОшибкуУстановкиДополнительнойОбработкиВОбластьДанных (БСП)

ОбластиТребующиеОбработки (БСП)

ВыполнитьОбновлениеКлассификаторовВОбластяхДанных (БСП)

УстановитьПоставляемуюОбработкуВОбластьДанных (БСП)

УдалитьПоставляемуюОбработкуИзОбластиДанных (БСП)

ОтозватьПоставляемуюДополнительнуюОбработку (БСП)

ЗаблокироватьДополнительныеОтчетыИОбработкиДляОбновления (БСП)

TurboConf - расширение Конфигуратора 1С