ПриПолученииПриоритетаОбновления (БСП)

Автор: 1С
ОбщийМодуль.ИнтеграцияПодсистемБСП
БСП

При получении приоритета обновления. Позволяет переопределить приоритет обновления, по умолчанию получаемый из константы СведенияОбОбновленииИБ.

// Позволяет переопределить приоритет обновления, по умолчанию получаемый из константы СведенияОбОбновленииИБ.
// Например, БТС может переопределить приоритет обновления для каждой области данных в режиме сервиса.
//
// Параметры:
//  Приоритет - Строка - новое значение приоритета обновления (возвращаемое). Возвращать можно следующие значения:
//              * "РаботаПользователей" - приоритет на обработку пользователей (в один поток);
//              * "ОбработкаДанных" - приоритет на обработку данных (в несколько потоков);
//              * Любое другое - использовать приоритет из константы СведенияОбОбновленииИБ (не переопределять).
//
Процедура ПриПолученииПриоритетаОбновления(Приоритет) Экспорт
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.РаботаВМоделиСервиса.ОбновлениеВерсииИБВМоделиСервиса") Тогда
		МодульОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса = ОбщегоНазначения.ОбщийМодуль("ОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса");
		МодульОбновлениеИнформационнойБазыСлужебныйВМоделиСервиса.ПриПолученииПриоритетаОбновления(Приоритет);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБТС().ПриПолученииПриоритетаОбновления Тогда
		МодульИнтеграцияПодсистемБТС = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБТС");
		МодульИнтеграцияПодсистемБТС.ПриПолученииПриоритетаОбновления(Приоритет);
	КонецЕсли;
	
	Если ИнтеграцияПодсистемБСППовтИсп.ПодпискиБИП().ПриПолученииПриоритетаОбновления Тогда
		МодульИнтеграцияПодсистемБИП = ОбщегоНазначения.ОбщийМодуль("ИнтеграцияПодсистемБИП");
		МодульИнтеграцияПодсистемБИП.ПриПолученииПриоритетаОбновления(Приоритет);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗавершитьПолучениеОбновления (БСП)

ПриоритетыВыполненияОбработчика (БСП)

НеПроверятьПриоритет (БСП)

СлужебнаяПараметрыПолученияОбновлений (БСП)

НовыйКонтекстПолученияИУстановкиОбновлений (БСП)

СоздатьКаталогиДляПолученияОбновления (БСП)

ПараметрыПолученияОбновлений (БСП)

ПриОпределенииПараметровПолученияОбновлений (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз