ОтмеченныеЭлементыСпискаЗначений (БСП)

Автор: 1С
ОбщийМодуль.ИнтернетПоддержкаПользователейКлиент
БСП

Отмеченные элементы списка значений. Возвращает массив, составленный из отмеченных значений списка значений.

// Возвращает массив, составленный из отмеченных значений списка значений.
//
// Параметры:
//  Список         - СписокЗначений, ДанныеФормыКоллекция - Список отмеченных значений;
//  ЗначениеОтбора - Булево - какое значение отбирать.
//
// Возвращаемое значение:
//   Массив - Массив отмеченных значений.
//
Функция ОтмеченныеЭлементыСпискаЗначений(Список, ЗначениеОтбора = Истина) Экспорт

	Результат = Новый Массив;

	Для Каждого ТекущийЭлементСписка Из Список Цикл
		Если ТекущийЭлементСписка.Пометка = ЗначениеОтбора Тогда
			Результат.Добавить(ТекущийЭлементСписка.Значение);
		КонецЕсли;
	КонецЦикла;

	Возврат Результат;

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтмеченныеЭлементы (БСП)

НайтиЭлементСпискаЗначений (БСП)

СпискиЗначенийИдентичны (БСП)

СнятьУсловноеОформлениеСпискаЗначений (БСП)

ЗначенияСписком (БСП)

Алгоритм перебора всех возможных сочетаний элементов

УстановитьЭлементОтбораДинамическогоСписка (БСП)

УдалитьЭлементыГруппыОтбораДинамическогоСписка (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз