ФорматированныйЗаголовок (БСП)

Автор: 1С
ОбщийМодуль.ИнтернетПоддержкаПользователейКлиентСервер
БСП

Форматированный заголовок. Преобразует переданную строку:

// Преобразует переданную строку:
// в форматированную строку, если строка начинается с "<body>" и заканчивается "</body>";
// В противном случае строка остается без изменений.
//
Функция ФорматированныйЗаголовок(ТекстСообщения) Экспорт

	Если Лев(ТекстСообщения, 6) <> "<body>" Тогда
		Возврат ТекстСообщения;
	Иначе
		#Если ВебКлиент Тогда
		Возврат ИнтернетПоддержкаПользователейВызовСервера.ФорматированнаяСтрокаИзHTML(ТекстСообщения);
		#Иначе
		Возврат ФорматированнаяСтрокаИзHTML(ТекстСообщения);
		#КонецЕсли
	КонецЕсли;

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ФорматированнаяСтрокаИзHTML (БСП)

Пример раскраски текста форматированной строки

ОбработатьТекстHTMLДляФорматированногоДокумента (БСП)

ТекстФорматированногоЗаголовка (БСП)

ОбработатьHTMLДляФорматированногоДокумента (БСП)

ЗаголовокПроизвольныхПараметров (БСП)

ЗаголовокОбщиеРеквизиты (БСП)

СформироватьЗаголовокКомментариев (БСП)

TurboConf - расширение Конфигуратора 1С