ОбновитьПроизводственныеКалендари (БСП)

Автор: 1С
ОбщийМодуль.КалендарныеГрафики
БСП

Обновить производственные календари. Обновляет справочник Производственные календари из одноименного макета.

// Обновляет справочник Производственные календари из одноименного макета.
//
Процедура ОбновитьПроизводственныеКалендари() Экспорт
	
	Если ОбщегоНазначения.ЭтоАвтономноеРабочееМесто() Тогда
		Возврат;
	КонецЕсли;
	
	ВерсияВстроенныхКалендарей = ВерсияКалендарей();
	Если ВерсияВстроенныхКалендарей <= ВерсияЗагруженныхКалендарей() Тогда
		Возврат;
	КонецЕсли;
	
	ТаблицаКалендарей = Справочники.ПроизводственныеКалендари.ПроизводственныеКалендариИзМакета();
	
	Если ТаблицаКалендарей.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Справочники.ПроизводственныеКалендари.ОбновитьПроизводственныеКалендари(ТаблицаКалендарей);
	ОбновитьИспользованиеНесколькихПроизводственныхКалендарей();
	
	ЗаполнитьДанныеПроизводственныхКалендарейПриОбновлении();
	
	Если ОбщегоНазначения.ПодсистемаСуществует("ИнтернетПоддержкаПользователей.РаботаСКлассификаторами") Тогда
		МодульРаботаСКлассификаторами = ОбщегоНазначения.ОбщийМодуль("РаботаСКлассификаторами");
		МодульРаботаСКлассификаторами.УстановитьВерсиюКлассификатора(ИдентификаторКлассификатора(), ВерсияВстроенныхКалендарей);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбновитьДанныеПроизводственныхКалендарей (БСП)

ОбновитьДанныеЗависимыхПроизводственныхКалендарей (БСП)

ОбновитьДанныеЗависимыеОтПроизводственныхКалендарей (БСП)

ОбновитьГрафикиРаботыПоДаннымПроизводственныхКалендарей (БСП)

ОбновитьИспользованиеНесколькихПроизводственныхКалендарей (БСП)

ПриОбновленииПроизводственныхКалендарей (БСП)

ОсновнойПроизводственныйКалендарь (БСП)

РаспространитьИзмененияДанныхПроизводственныхКалендарей (БСП)

TurboConf 6 - расширение Конфигуратора 1С