ПолучитьПревьюРасширенийВФоне (БСП)

Автор: 1С
ОбщийМодуль.КаталогРасширений
БСП

Получить превью расширений фоне. Формирует список дополнительных параметров для запроса данных превью указанных расширений,

// Формирует список дополнительных параметров для запроса данных превью указанных расширений, 
//	и запускает выполнение запроса в фоновом задании.
//
// Параметры:
//	АдресХранилищаРезультат - Строка - адрес временного хранилища в которое будет помещен результат выполнения запроса.
//	ИдентификаторыВерсийРасширений - Массив - массив идентификаторов расширений превью которых требуется получить.
//
// Возвращаемое значение:
//   Булево - Истина, если удалось запустить фоновое задание.
//
Функция ПолучитьПревьюРасширенийВФоне(АдресХранилищаРезультат, ИдентификаторыВерсийРасширений) Экспорт 
	
	Если ТипЗнч(ИдентификаторыВерсийРасширений) <> Тип("Массив") Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru = 'Идентификаторы версий расширений должны передаваться в виде массива.'"));	
		Возврат Ложь;	
	КонецЕсли;
	
	Если ИдентификаторыВерсийРасширений.Количество() = 0 Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru = 'Не указаны идентификаторы версий расширений'"));	
		Возврат Ложь;
	КонецЕсли;
	
	СинонимыДопПараметровМетодов = КаталогРасширенийПовтИсп.СинонимыДопПараметровМетодов();
	
	ДопПараметры = Новый Структура;
	ДопПараметры.Вставить(СинонимыДопПараметровМетодов.Получить("ИдентификаторыВерсийРасширений"), ИдентификаторыВерсийРасширений);
	
	Возврат НачатьВыполнениеЗапроса(АдресХранилищаРезультат, ДопПараметры, "ПолучитьПревьюРасширений");	
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПолучитьСтатусРасширенияВФоне (БСП)

ПолучитьСписокДоступныхРасширенийВФоне (БСП)

ПолучитьСписокНайденныхРасширенийВФоне (БСП)

ПолучитьДанныеВерсииРасширенияВФоне (БСП)

ОтправитьПолучитьПочтуПользователяВФоне (БСП)

ПолучитьРезультатВыполненияВФоне (БСП)

ОтправлятьПревью (БСП)

НачатьУстановкуРасширенияВФоне (БСП)

НачатьУдалениеРасширенияВФоне (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз