ПроверитьДублированиеПредопределенныхЭлементов (БСП)

Автор: 1С
ОбщийМодуль.КонтрольВеденияУчетаСлужебный
БСП

Проверить дублирование предопределенных элементов. Исполняет проверку наличия дублирующихся предопределенных элементов.

// Исполняет проверку наличия дублирующихся предопределенных элементов.
//
Процедура ПроверитьДублированиеПредопределенныхЭлементов(Проверка, ПараметрыПроверки) Экспорт
	
	ВидыОбъектовМетаданных = Новый Массив;
	ВидыОбъектовМетаданных.Добавить(Метаданные.Справочники);
	ВидыОбъектовМетаданных.Добавить(Метаданные.ПланыВидовХарактеристик);
	ВидыОбъектовМетаданных.Добавить(Метаданные.ПланыСчетов);
	ВидыОбъектовМетаданных.Добавить(Метаданные.ПланыВидовРасчета);
	
	Для Каждого ВидМетаданных Из ВидыОбъектовМетаданных Цикл
		
		Если ВидМетаданных.Количество() = 0 Тогда
			Продолжить;
		КонецЕсли;
		
		НайтиДублиПредопределенныхЭлементов(ВидМетаданных, ПараметрыПроверки);
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПроверитьОтсутствующиеПредопределенныеЭлементы (БСП)

ПредопределенныйЭлемент (БСП)

ЗаменитьСсылкиНаПредопределенныеЭлементы (БСП)

ИменаПредопределенныхЭлементовСправочника (БСП)

ОбъектыМетаданныхСПредопределеннымиЭлементами (БСП)

СоздатьНеразделенныеПредопределенныеЭлементы (БСП)

ЗапретитьУдалениеПредопределенныхЭлементовПередУдалением (БСП)

TurboConf ИР адаптер 1.37