ЯзыкПоКоду (БСП)

Автор: 1С
ОбщийМодуль.ЛокализацияСервер
БСП

Язык по коду. Возвращает метаданные по коду языка конфигурации.

// Возвращает метаданные по коду языка конфигурации.
//
// Параметры:
//   КодЯзыка - Строка - код языка, например "en" (как задано в свойстве КодЯзыка метаданных ОбъектМетаданных: Язык).
//
// Возвращаемое значение:
//   ОбъектМетаданных: Язык - если найден по переданному коду языка, иначе Неопределено.
//   
Функция ЯзыкПоКоду(Знач КодЯзыка) Экспорт
	Для каждого Язык Из Метаданные.Языки Цикл
		Если Язык.КодЯзыка = КодЯзыка Тогда
			Возврат Язык;
		КонецЕсли;	
	КонецЦикла;
	Возврат Неопределено;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЯзыкПоКоду (БСП)

КодОсновногоЯзыка (БСП)

ПриОпределенииКодаЯзыкаИнтерфейсаКонфигурации (БСП)

СинтаксисЯзыка (БСП)

Язык выражений СКД Формат()

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз