ПроверитьСоставПланаОбмена (БСП)

Автор: 1С
ОбщийМодуль.МиграцияПриложений
БСП

Проверить состав плана обмена. Проверяет состав плана обмена, в случае некорректного состава вызывается исключение.

// Проверяет состав плана обмена, в случае некорректного состава вызывается исключение.
// Проверки:
//   1) У всех объектов выключена авторегистрация. 
//   2) В составе есть все объекты необходимые для обмена.
//
Процедура ПроверитьСоставПланаОбмена() Экспорт
	
	СоставПланаОбмена = Новый Соответствие;
	Для Каждого Состав Из Метаданные.ПланыОбмена.МиграцияПриложений.Состав Цикл
		Если Состав.АвтоРегистрация = АвтоРегистрацияИзменений.Разрешить Тогда
			ВызватьИсключение НСтр("ru = 'Некорректно настроен план обмена ""Миграция приложений"": авторегистрация должна быть выключена.'");
		КонецЕсли;
		СоставПланаОбмена.Вставить(Состав.Метаданные, Истина);
	КонецЦикла;
	
	Для Каждого ЗагружаемыйОбъект Из МиграцияПриложенийПовтИсп.ВыгружаемыеОбъекты() Цикл
		Если СоставПланаОбмена.Получить(ЗагружаемыйОбъект.Ключ) = Неопределено Тогда
			Шаблон = НСтр("ru = 'Некорректно настроен план обмена ""Миграция приложений"": в состав нужно добавить %1.'");
			ВызватьИсключение СтрШаблон(Шаблон, ЗагружаемыйОбъект.Ключ.ПолноеИмя());
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПользовательскийСоставПланаОбмена (БСП)

ПланОбменаСодержитОбъект (БСП)

СоставПланаОбмена (БСП)

ПроверитьНаличиеПредопределенныхУзловПлановОбмена (БСП)

НазначениеПланаОбмена (БСП)

ЕстьМакетПланаОбмена (БСП)

ПланыОбменаРИБ (БСП)

ЭтоПланОбменаXDTO (БСП)

TurboConf - расширение Конфигуратора 1С