ТипыСопоставляемыхОбщихДанныхПоПредопределенномуИмени (БСП)

Автор: 1С
ОбщийМодуль.МиграцияПриложенийПовтИсп
БСП

Типы сопоставляемых общих данных по предопределенному имени. Возвращает типы ссылок общих данных, сопоставляемых по предопределенному имени.

// Возвращает типы ссылок общих данных, сопоставляемых по предопределенному имени.
//
// Возвращаемое значение:
//   Соответствие - коллекция типов ссылок.
//
Функция ТипыСопоставляемыхОбщихДанныхПоПредопределенномуИмени() Экспорт
	
	Типы = Новый Соответствие;
	
	РазделенныеОбъектыМетаданных = МиграцияПриложенийПовтИсп.МодельДанныхОбласти();
	РазрешенныеОбщиеДанные = ВыгрузкаЗагрузкаДанныхСлужебныйСобытия.ПолучитьТипыОбщихДанныхПоддерживающиеСопоставлениеСсылокПриЗагрузке();
	
	Для Каждого ВидМетаданных Из ВидыМетаданныхСПредопределенными() Цикл
		Для Каждого ОбъектМетаданных Из ВидМетаданных Цикл
			Если РазделенныеОбъектыМетаданных[ОбъектМетаданных] <> Неопределено Тогда
				Продолжить;
			КонецЕсли;
			Если РазрешенныеОбщиеДанные.Найти(ОбъектМетаданных) <> Неопределено Тогда
				Продолжить;
			КонецЕсли;
			Если ОбъектМетаданных.ПолучитьИменаПредопределенных().Количество() <> 0 Тогда
				Типы.Вставить(ОбъектМетаданных.СтандартныеРеквизиты.Ссылка.Тип.Типы()[0], Истина);
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	Возврат Типы;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ТипыСопоставляемыхОбщихДанныхПоПолямПоиска (БСП)

ПредопределенныйЭлемент (БСП)

ЭтоПолноеИмяПеречисления (БСП)

ЭтоПолноеИмяПланаСчетов (БСП)

ЭтоПолноеИмяРегистраНакопления (БСП)

ЭтоПолноеИмяПоследовательности (БСП)

ЭтоПолноеИмяДокумента (БСП)

ЭтоПолноеИмяСправочника (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз