ФормаНастройкиПередЗакрытием (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиКлиент
БСП

Форма настройки перед закрытием.

//
Процедура ФормаНастройкиПередЗакрытием(Отказ, Форма, ЗавершениеРаботы) Экспорт
	
	ИмяПроцедуры = "ОбменДаннымиКлиент.ФормаНастройкиПередЗакрытием";
	ОбщегоНазначенияКлиентСервер.ПроверитьПараметр(ИмяПроцедуры, "Отказ", Отказ, Тип("Булево"));
	ОбщегоНазначенияКлиентСервер.ПроверитьПараметр(ИмяПроцедуры, "Форма", Форма, Тип("ФормаКлиентскогоПриложения"));
	ОбщегоНазначенияКлиентСервер.ПроверитьПараметр(ИмяПроцедуры, "ЗавершениеРаботы", ЗавершениеРаботы, Тип("Булево"));
	
	Если Не Форма.Модифицированность Тогда
		Возврат;
	КонецЕсли;
		
	Отказ = Истина;
	
	Если ЗавершениеРаботы Тогда
		Возврат;
	КонецЕсли;
	
	ТекстВопроса = НСтр("ru = 'Данные были изменены. Закрыть форму без сохранения изменений?'");
	ОписаниеОповещения = Новый ОписаниеОповещения("ФормаНастройкиПередЗакрытиемЗавершение", ЭтотОбъект, Форма);
	ПоказатьВопрос(ОписаниеОповещения, ТекстВопроса, РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Нет);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ФормаНастройкиПередЗакрытиемЗавершение (БСП)

ФормаНастройкиУзловКомандаЗакрытьФорму (БСП)

ФормаНастройкиУзлаКомандаЗакрытьФорму (БСП)

ЗавершитьНастройкуРазрешенийНаИспользованиеВнешнихРесурсов (БСП)

ПрерватьНастройкуРазрешенийНаИспользованиеВнешнихРесурсов (БСП)

ПослеЗакрытияФормыПовторнаяСинхронизацияДанныхПередЗапуском (БСП)

ФормаНастройкиЗначенийПоУмолчаниюКомандаЗакрытьФорму (БСП)

ПодтвердитьЗакрытиеФормы (БСП)

ПередНастройкойПараметровПодключения (БСП)

TurboConf - расширение Конфигуратора 1С