ИспользуетсяВерсионирование (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиПовтИсп
БСП

Используется версионирование. Определяет используется ли версионирование.

// Определяет используется ли версионирование.
//
// Параметры:
//	Отправитель - ПланОбменаСсылка - Если параметр передается, то определяет необходимо
//		ли использовать создание версий объектов для переданного узла.
//
Функция ИспользуетсяВерсионирование(Отправитель = Неопределено, ПроверятьПраваДоступа = Ложь) Экспорт
	
	Используется = Ложь;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ВерсионированиеОбъектов") Тогда
		
		Используется = ?(Отправитель <> Неопределено, ЭтоУзелОбменаДаннымиБСП(Отправитель), Истина);
		
		Если Используется И ПроверятьПраваДоступа Тогда
			
			МодульВерсионированиеОбъектов = ОбщегоНазначения.ОбщийМодуль("ВерсионированиеОбъектов");
			Используется = МодульВерсионированиеОбъектов.ЕстьПравоЧтенияИнформацииОВерсияхОбъектов();
			
		КонецЕсли;
			
	КонецЕсли;
	
	Возврат Используется;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

КоличествоПроблемВерсионирования (БСП)

ЗаписатьНастройкуВерсионированияПоОбъекту (БСП)

ПараметрыЗапросаКоличествоПроблемВерсионирования (БСП)

ВключеноВерсионированиеОбъекта (БСП)

ВключеноВерсионированиеОбъектов (БСП)

ОбновитьНастройкиВерсионированияОбъектов (БСП)

ПоказатьНастройку (БСП)

ИспользуетсяПочтовыйКлиент (БСП)

ИспользуетсяПрочиеВзаимодействия (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз