КоличествоПроблемВерсионирования (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиСервер
БСП

Количество проблем версионирования.

Функция КоличествоПроблемВерсионирования(УзлыОбмена = Неопределено, Знач ПараметрыЗапроса = Неопределено) Экспорт
	
	Если ПараметрыЗапроса = Неопределено Тогда
		ПараметрыЗапроса = ПараметрыЗапросаКоличествоПроблемВерсионирования();
	КонецЕсли;
	
	ИспользуетсяВерсионирование = ОбменДаннымиПовтИсп.ИспользуетсяВерсионирование(, Истина);
	
	Если ИспользуетсяВерсионирование Тогда
		МодульВерсионированиеОбъектов = ОбщегоНазначения.ОбщийМодуль("ВерсионированиеОбъектов");
		Возврат МодульВерсионированиеОбъектов.КоличествоКоллизийИлиНепринятых(
			УзлыОбмена,
			ПараметрыЗапроса.ЭтоКоличествоКоллизий,
			ПараметрыЗапроса.УчитыватьПроигнорированные,
			ПараметрыЗапроса.Период,
			ПараметрыЗапроса.СтрокаПоиска);
	КонецЕсли;
		
	Возврат 0;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПараметрыЗапросаКоличествоПроблемВерсионирования (БСП)

КоличествоПроблемПоОбъекту (БСП)

КоличествоПроблемПоПравилуПроверки (БСП)

КоличествоНерассмотренныхПроблем (БСП)

СводнаяИнформацияПоВидамПроверок (БСП)

ИспользуетсяВерсионирование (БСП)

ЗаписатьНастройкуВерсионированияПоОбъекту (БСП)

ВключеноВерсионированиеОбъекта (БСП)

ВключеноВерсионированиеОбъектов (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз