ОтключитьАвтоматическуюСинхронизациюДанныхПриЗаписи (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиСобытия
БСП

Отключить автоматическую синхронизацию данных при записи.

Процедура ОтключитьАвтоматическуюСинхронизациюДанныхПриЗаписи(Источник, Отказ, Замещение) Экспорт
	
	Если Источник.ОбменДанными.Загрузка Тогда
		Возврат;
	КонецЕсли;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.РаботаВМоделиСервиса.ОбменДаннымиВМоделиСервиса") Тогда
		МодульАвтономнаяРабота = ОбщегоНазначения.ОбщийМодуль("АвтономнаяРабота");
		МодульАвтономнаяРабота.ОтключитьАвтоматическуюСинхронизациюДанныхСПриложениемВИнтернете(Источник);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОтключитьАвтоматическуюСинхронизациюДанныхСПриложениемВИнтернете (БСП)

ВключитьОтключитьАвтоматическуюУстановкуИсправлений (БСП)

ОтключенаЛогикаНачалаРаботыСистемы (БСП)

УдалитьНастройкуСинхронизации (БСП)

ОписаниеПравилСинхронизацииДанных (БСП)

СобытиеЖурналаРегистрацииСинхронизацииДанных (БСП)

СинхронизацияДанныхПоддерживается (БСП)

TurboConf - расширение Конфигуратора 1С