ПроверитьИзменениеФильтровОграниченияМиграцииДанныхПриЗаписи (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиСобытия
БСП

Проверить изменение фильтров ограничения миграции данных при записи.

Процедура ПроверитьИзменениеФильтровОграниченияМиграцииДанныхПриЗаписи(Источник, Отказ) Экспорт
	
	Если Источник.ОбменДанными.Загрузка Тогда
		Возврат;
	КонецЕсли;
	
	Если Не ОбменДаннымиПовтИсп.ЭтоУзелОбменаДаннымиБСП(Источник.Ссылка) Тогда
		Возврат;
	КонецЕсли;
	
	ЗарегистрированныеКВыгрузкеОбъекты = Неопределено;
	Если Источник.ДополнительныеСвойства.Свойство("ЗарегистрированныеКВыгрузкеОбъекты", ЗарегистрированныеКВыгрузкеОбъекты) Тогда
		
		ОбменДаннымиСлужебный.ОбновитьКэшМеханизмаРегистрацииОбъектов();
		
		Для Каждого Объект Из ЗарегистрированныеКВыгрузкеОбъекты Цикл
			
			Если Не ВыгрузкаОбъектаРазрешена(Источник.Ссылка, Объект) Тогда
				
				ПланыОбмена.УдалитьРегистрациюИзменений(Источник.Ссылка, Объект);
				
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЕсли;
	
	ТаблицаРеквизитовСсылочногоТипа = Неопределено;
	Если Источник.ДополнительныеСвойства.Свойство("ТаблицаРеквизитовУзла", ТаблицаРеквизитовСсылочногоТипа) Тогда
		
		// Выполняем регистрацию выбранных объектов ссылочного типа на текущем узле без использования ПРО.
		ВыполнитьРегистрациюОбъектовСсылочногоТипаПоСвойствамУзла(Источник, ТаблицаРеквизитовСсылочногоТипа);
		
		// Обновляем повторно используемые значения механизма.
		ОбменДаннымиСлужебный.СброситьКэшМеханизмаРегистрацииОбъектов();
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗарегистрироватьИзмененияФильтровОграниченияМиграцииДанных (БСП)

ПриИзмененииОграниченияДоступаНаУровнеЗаписей (БСП)

ПроверитьДатуЗапретаИзмененияПередЗаписьюДокумента (БСП)

ИнтерактивноеИзменениеВыгрузкиФильтрВарианта (БСП)

ПроверитьДатуЗапретаИзмененияПередЗаписьюНабораЗаписей (БСП)

ПроверитьДатуЗапретаИзмененияПередЗаписью (БСП)

ПроверитьВозможностьИзмененияНастроекОбменаДанными (БСП)

ПроверитьДатуЗапретаИзмененияПередЗаписьюНабораЗаписейРегистраБухгалтерии (БСП)

TurboConf ИР адаптер 1.37