ОбъектXDTOВСтруктуру (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиXDTOСервер
БСП

Объект xdto структуру. Выполняет преобразование объекта XDTO в структуру с данными.

// Выполняет преобразование объекта XDTO в структуру с данными.
//
// Параметры:
//  ОбъектXDTO - ОбъектXDTO - Значение, которое необходимо преобразовать.
//
// Возвращаемое значение:
//  Структура - Структура, имитирующая объект XDTO.
//    Ключи структуры соответствуют свойствам объекта XDTO.
//    Значения соответствуют значениям свойств объекта XDTO.
//
Функция ОбъектXDTOВСтруктуру(ОбъектXDTO) Экспорт
	
	Приемник = Новый Структура;
	
	Для Каждого Свойство Из ОбъектXDTO.Свойства() Цикл
		
		КонвертацияСвойстваXDTOВЭлементСтруктуры(ОбъектXDTO, Свойство, Приемник);
		
	КонецЦикла;
	
	Если Приемник.Свойство("КлючевыеСвойства")
		И Приемник.КлючевыеСвойства.Свойство("Ссылка") Тогда
		Приемник.Вставить("Ссылка", Приемник.КлючевыеСвойства.Ссылка);
	КонецЕсли;
	
	Возврат Приемник;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СкопироватьСтруктуру (БСП)

Реквизиты Объекта в Структуру

ФайлОбъект (БСП)

СтруктураОграниченияИзОписания (БСП)

Разложить массив по типам объектов

Получить Реквизиты Объекта В Структуру

СведенияОВерсииОбъекта (БСП)

СтруктураОбъектаXDTOВДанныеИБ (БСП)

ПолучитьИнформациюДляПеремещения (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз