ПропускатьОбъектыСОшибкамиПроверкиПоСхеме (БСП)

Автор: 1С
ОбщийМодуль.ОбменДаннымиXDTOСервер
БСП

Пропускать объекты ошибками проверки по схеме. Возвращает признак режима пропуска при выгрузке объектов формата, не прошедших проверку по схеме.

// Возвращает признак режима пропуска при выгрузке объектов формата, не прошедших проверку по схеме.
// Может быть использована для установки нового значения режима.
//
// Параметры:
//   УзелИнформационнойБазы - ПланОбменаСсылка - узел плана обмена, соответствующий корреспонденту.
//   НовоеЗначение - Булево, Неопределено - новое значение режима для установки.
//                                          Если Неопределено, то значение режима не изменяется.
//
// Возвращаемое значение:
//   Булево - Истина, если при отправке данных необходимо пропускать объекты формата.
//
Функция ПропускатьОбъектыСОшибкамиПроверкиПоСхеме(УзелИнформационнойБазы, НовоеЗначение = Неопределено) Экспорт
	
	Режим = Ложь;
	
	УстановитьПривилегированныйРежим(Истина);
	
	МенеджерЗаписи = РегистрыСведений.НастройкиОбменаДаннымиXDTO.СоздатьМенеджерЗаписи();
	МенеджерЗаписи.УзелИнформационнойБазы = УзелИнформационнойБазы;
	МенеджерЗаписи.Прочитать();
	
	Если НовоеЗначение = Неопределено Тогда
		Если МенеджерЗаписи.Выбран() Тогда
			Режим = МенеджерЗаписи.ПропускатьОбъектыСОшибкамиПроверкиПоСхеме;
		КонецЕсли;
	Иначе
		МенеджерЗаписи.ПропускатьОбъектыСОшибкамиПроверкиПоСхеме = НовоеЗначение;
		МенеджерЗаписи.Записать(Истина);
		
		Режим = НовоеЗначение;
	КонецЕсли;
	
	Возврат Режим;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

Чтение файла XML в объект XDTO по схеме *.xsd

Проверка_ПослеВыполненияVerifySign_Ошибка (БСП)

Проверка_ПослеВыполненияGetSignOIDFromCert_Ошибка (БСП)

Проверка_ПослеВыполненияC14N_SignedInfo_Ошибка (БСП)

Проверка_ПослеВыполненияC14N_ПодписываемыйТег_Ошибка (БСП)

Проверка_ПослеВыполненияHash_ПодписываемыйТег_Ошибка (БСП)

ТекстОшибкиПроверкиПраваДобавления (БСП)

ЗарегистрироватьОшибкуЗаписиОбъекта (БСП)

ПроверитьПодписьНаКлиентеПослеОшибкиПроверкиПодписиXMLDSig (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз