ПодтвердитьЗакрытиеФормы (БСП)

Автор: 1С
ОбщийМодуль.ОбщегоНазначенияСлужебныйКлиент
БСП

Подтвердить закрытие формы.

Процедура ПодтвердитьЗакрытиеФормы() Экспорт
	
	ИмяПараметра = "СтандартныеПодсистемы.ПараметрыПодтвержденияЗакрытияФормы";
	Если ПараметрыПриложения[ИмяПараметра] = Неопределено Тогда
		ПараметрыПриложения.Вставить(ИмяПараметра, Неопределено);
	КонецЕсли;
	
	Параметры = ПараметрыПриложения["СтандартныеПодсистемы.ПараметрыПодтвержденияЗакрытияФормы"];
	Если Параметры = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Оповещение = Новый ОписаниеОповещения("ПодтвердитьЗакрытиеФормыЗавершение", ЭтотОбъект, Параметры);
	Если ПустаяСтрока(Параметры.ТекстПредупреждения) Тогда
		ТекстВопроса = НСтр("ru = 'Данные были изменены. Сохранить изменения?'");
	Иначе
		ТекстВопроса = Параметры.ТекстПредупреждения;
	КонецЕсли;
	
	ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНетОтмена, ,
		КодВозвратаДиалога.Нет);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПодтвердитьЗакрытиеФормыЗавершение (БСП)

ПодтвердитьЗакрытиеПроизвольнойФормы (БСП)

ПодтвердитьЗакрытиеПроизвольнойФормыЗавершение (БСП)

ПодтвердитьЗакрытиеПроизвольнойФормыСейчас (БСП)

ПодтвердитьЗакрытиеФормыСейчас (БСП)

ФормаНастройкиПередЗакрытием (БСП)

ПоказатьПодтверждениеЗакрытияФормы (БСП)

ПоказатьПодтверждениеЗакрытияФормыСФайлами (БСП)

ОткрытьФормуПослеЗакрытияТекущей (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз