ПодтвердитьЗакрытиеПроизвольнойФормы (БСП)

Автор: 1С
ОбщийМодуль.ОбщегоНазначенияСлужебныйКлиент
БСП

Подтвердить закрытие произвольной формы.

Процедура ПодтвердитьЗакрытиеПроизвольнойФормы() Экспорт
	
	ИмяПараметра = "СтандартныеПодсистемы.ПараметрыПодтвержденияЗакрытияФормы";
	Если ПараметрыПриложения[ИмяПараметра] = Неопределено Тогда
		ПараметрыПриложения.Вставить(ИмяПараметра, Неопределено);
	КонецЕсли;
	
	Параметры = ПараметрыПриложения["СтандартныеПодсистемы.ПараметрыПодтвержденияЗакрытияФормы"];
	Если Параметры = Неопределено Тогда
		Возврат;
	КонецЕсли;
	ПараметрыПриложения["СтандартныеПодсистемы.ПараметрыПодтвержденияЗакрытияФормы"] = Неопределено;
	РежимВопроса = РежимДиалогаВопрос.ДаНет;
	
	Оповещение = Новый ОписаниеОповещения("ПодтвердитьЗакрытиеПроизвольнойФормыЗавершение", ЭтотОбъект, Параметры);
	
	ПоказатьВопрос(Оповещение, Параметры.ТекстПредупреждения, РежимВопроса);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПодтвердитьЗакрытиеПроизвольнойФормыЗавершение (БСП)

ПодтвердитьЗакрытиеПроизвольнойФормыСейчас (БСП)

ПодтвердитьЗакрытиеФормы (БСП)

ПодтвердитьЗакрытиеФормыЗавершение (БСП)

ПодтвердитьЗакрытиеФормыСейчас (БСП)

ПоказатьПодтверждениеЗакрытияПроизвольнойФормы (БСП)

ФормаНастройкиПередЗакрытием (БСП)

ПоказатьПодтверждениеЗакрытияФормы (БСП)

ПоказатьПодтверждениеЗакрытияФормыСФайлами (БСП)

TurboConf 6 - расширение Конфигуратора 1С