ОбработкаОповещенияИзмененияФлажкаИспользоватьПоиск (БСП)

Автор: 1С
ОбщийМодуль.ПолнотекстовыйПоискКлиент
БСП

Обработка оповещения изменения флажка использовать поиск. Обработчик события ОбработкаОповещения для формы, на которой требуется отобразить флажок использования поиска.

// Обработчик события ОбработкаОповещения для формы, на которой требуется отобразить флажок использования поиска.
//
// Параметры:
//   ИмяСобытия - Строка - имя события, которое было получено обработчиком события на форме.
//   ИспользоватьПолнотекстовыйПоиск - Число - реквизит, в который будет помещено значение.
// 
// Пример:
//	Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("СтандартныеПодсистемы.ПолнотекстовыйПоиск") Тогда
//		МодульПолнотекстовыйПоискКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("ПолнотекстовыйПоискКлиент");
//		МодульПолнотекстовыйПоискКлиент.ОбработкаОповещенияИзмененияФлажкаИспользоватьПоиск(
//			ИмяСобытия, 
//			ИспользоватьПолнотекстовыйПоиск);
//	КонецЕсли;
//
Процедура ОбработкаОповещенияИзмененияФлажкаИспользоватьПоиск(Знач ИмяСобытия, ИспользоватьПолнотекстовыйПоиск) Экспорт
	
	Если ИмяСобытия = "ИзменилсяРежимПолнотекстовогоПоиска" Тогда
		ИспользоватьПолнотекстовыйПоиск = ПолнотекстовыйПоискСлужебныйВызовСервера.ЗначениеФлажкаИспользоватьПоиск();
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПриИзмененииФлажкаИспользоватьПоиск (БСП)

ЗначениеФлажкаИспользоватьПоиск (БСП)

ОбработкаОповещенияИзмененияФлажкаУдалятьПоРасписанию (БСП)

ОбработкаОповещенияИзмененияФлажкаХранитьИсторию (БСП)

ОбработатьОповещениеОбИзменении (БСП)

ОповещениеОбИзменении (БСП)

ОповещенияОбИзмененияхНеИспользуются (БСП)

ПриИзмененииФлажкаХранитьИсторию (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз