ПослеОбновленияСоставовГруппВнешнихПользователей (БСП)

Автор: 1С
ОбщийМодуль.ПользователиСлужебный
БСП

После обновления составов групп внешних пользователей. Только для внутреннего использования.

// Только для внутреннего использования.
Процедура ПослеОбновленияСоставовГруппВнешнихПользователей(УчастникиИзменений, ИзмененныеГруппы) Экспорт
	
	Если УчастникиИзменений.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	УчастникиИзмененийМассив = Новый Массив;
	Для каждого КлючИЗначение Из УчастникиИзменений Цикл
		УчастникиИзмененийМассив.Добавить(КлючИЗначение.Ключ);
	КонецЦикла;
	
	ОбновитьРолиВнешнихПользователей(УчастникиИзмененийМассив);
	
	ИзмененныеГруппыМассив = Новый Массив;
	Для каждого КлючИЗначение Из ИзмененныеГруппы Цикл
		ИзмененныеГруппыМассив.Добавить(КлючИЗначение.Ключ);
	КонецЦикла;
	
	ИнтеграцияПодсистемБСП.ПослеОбновленияСоставовГруппПользователей(УчастникиИзмененийМассив,
		ИзмененныеГруппыМассив);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПослеОбновленияСоставовГруппПользователей (БСП)

ОбновитьСоставыГруппВнешнихПользователей (БСП)

ОбновитьСоставыГруппПользователей (БСП)

ОбновитьИспользуемостьСоставовГруппПользователей (БСП)

ПроверитьОбновитьСоставСвойствГруппы (БСП)

ЗаполнитьНомераКартинокПользователей (БСП)

TurboConf - расширение Конфигуратора 1С