СтрокаПолей (БСП)

Автор: 1С
ОбщийМодуль.РаботаСАдресами
БСП

Строка полей. Возвращает строку списка полей.

//  Возвращает строку списка полей.
//
//  Параметры:
//    СтруктураЗначенийПолей - Структура - структура значений полей.
//    БезПустыхПолей         - Булево - необязательный флаг сохранения полей с пустыми значениями.
//
//  Возвращаемое значение:
///     Строка - результат преобразования из структуры.
//
Функция СтрокаПолей(СтруктураЗначенийПолей, БезПустыхПолей = Истина) Экспорт
	
	Результат = "";
	Для Каждого ЗначениеПоля Из СтруктураЗначенийПолей Цикл
		Если БезПустыхПолей И ПустаяСтрока(ЗначениеПоля.Значение) Тогда
			Продолжить;
		КонецЕсли;
		
		Результат = Результат + ?(Результат = "", "", Символы.ПС)
		            + ЗначениеПоля.Ключ + "=" + СтрЗаменить(ЗначениеПоля.Значение, Символы.ПС, Символы.ПС + Символы.Таб);
	КонецЦикла;
	
	Возврат Результат;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СтруктураЗначенийПолей (БСП)

ПреобразоватьСтрокуВСписокПолей (БСП)

Проверка заполненности полей объекта и возврат статуса + незаполненных полей

ПолучитьИдентификаторСтрокиДереваПоЗначениюПоля (БСП)

ДозаполнитьПоляКонтактов (БСП)

АвтоПодборАдреса (БСП)

КонтактнаяИнформацияПоПредставлению (БСП)

Открытие значения текущей строки колонки ТабличногоПоля на УФ

Оформление (раскраска) строки табличной части обычной формы по условию, при получении данных

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз