ВыполнитьДействияПередУдалениемПрисоединенногоФайла (БСП)

Автор: 1С
ОбщийМодуль.РаботаСФайлами
БСП

Выполнить действия перед удалением присоединенного файла. Обработчик подписки на событие ПередУдалением для удаления данных, связанных с присоединенным файлом.

// Обработчик подписки на событие ПередУдалением для удаления данных, связанных с присоединенным файлом.
//
// Параметры:
//  Источник   - СправочникОбъект - объект справочника с именем "*ПрисоединенныеФайлы".
//  Отказ      - Булево - параметр, передаваемый в подписку на событие ПередЗаписью.
//
Процедура ВыполнитьДействияПередУдалениемПрисоединенногоФайла(Источник, Отказ) Экспорт
	
	Если Источник.ОбменДанными.Загрузка Тогда
		Возврат;
	КонецЕсли;
	
	Если ТипЗнч(Источник) = Тип("СправочникОбъект.ВерсииФайлов") Тогда
		Возврат;
	КонецЕсли;
	
	РаботаСФайламиСлужебный.ПередУдалениемПрисоединенногоФайлаСервер(
		Источник.Ссылка,
		Источник.ВладелецФайла,
		Источник.Том,
		Источник.ТипХраненияФайла,
		Источник.ПутьКФайлу);
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВыполнитьДействияПередЗаписьюПрисоединенногоФайла (БСП)

ПередУдалениемПрисоединенногоФайлаСервер (БСП)

ВыполнитьДействияПриЗаписиПрисоединенногоФайла (БСП)

ПередНачаломРаботыСистемы (БСП)

ПередЗавершениемРаботыСистемы (БСП)

УстановитьПометкуУдаленияПрисоединенныхФайловДокументов (БСП)

УстановитьПометкуУдаленияПрисоединенныхФайлов (БСП)

ВыполнитьДействие (БСП)

ВыполнитьДействиеЗавершение (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз