ОбработатьФайлПослеПолученияТолькоЧтения (БСП)

Автор: 1С
ОбщийМодуль.РаботаСФайламиСлужебныйКлиент
БСП

Обработать файл после получения только чтения. Продолжение процедуры ОбработатьФайл.

// Продолжение процедуры ОбработатьФайл.
Процедура ОбработатьФайлПослеПолученияТолькоЧтения(ТолькоЧтение, Контекст) Экспорт
	
	Если ТолькоЧтение <> Null Тогда
		Контекст.СвойстваДляПолучения.ТолькоЧтение = ТолькоЧтение;
	КонецЕсли;
	
	Если Контекст.СвойстваДляПолучения.Свойство("Невидимость") Тогда
		Контекст.Файл.НачатьПолучениеНевидимости(Новый ОписаниеОповещения(
			"ОбработатьФайлПослеПолученияНевидимости", ЭтотОбъект, Контекст,
			"ОбработатьФайлПослеОшибки", ЭтотОбъект));
	Иначе
		ОбработатьФайлПослеПолученияНевидимости(Null, Контекст);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбработатьФайлПослеУстановкиТолькоЧтения (БСП)

ОбработатьФайлПослеПолученияФайлов (БСП)

ОбработатьФайлПослеПолученияНевидимости (БСП)

ОбработатьФайлПослеПолученияРазмера (БСП)

ОбработатьФайлПослеПолученияВремениИзменения (БСП)

ОбработатьФайлПослеПолученияУниверсальногоВремениИзменения (БСП)

ОбработатьФайлПослеУдаленияФайлов (БСП)

ОбработатьФайлПослеКопированияФайла (БСП)

ОбработатьФайлПослеПомещенияФайлов (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз