ЗакончитьРедактированиеСРасширениемПослеОтветаНаВопросОсвободитьФайл (БСП)

Автор: 1С
ОбщийМодуль.РаботаСФайламиСлужебныйКлиент
БСП

Закончить редактирование расширением после ответа на вопрос освободить файл. Продолжение процедуры (см. выше).

// Продолжение процедуры (см. выше).
Процедура ЗакончитьРедактированиеСРасширениемПослеОтветаНаВопросОсвободитьФайл(Ответ, ПараметрыВыполнения) Экспорт
	Если Ответ <> -1 Тогда
		Если Ответ = КодВозвратаДиалога.Да Тогда
			ПараметрыВыполнения.ОсвобождатьФайлы = Истина;
		Иначе
			ПараметрыВыполнения.ОсвобождатьФайлы = Ложь;
		КонецЕсли;
	КонецЕсли;
	
	Если ПараметрыВыполнения.ОсвобождатьФайлы Тогда
		ОсвободитьФайлБезВопроса(ПараметрыВыполнения.ДанныеФайла, ПараметрыВыполнения.ИдентификаторФормы);
		ВернутьРезультат(ПараметрыВыполнения.ОбработчикРезультата, Истина);
	Иначе
		ВернутьРезультат(ПараметрыВыполнения.ОбработчикРезультата, Ложь);
	КонецЕсли;
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗакончитьРедактированиеСРасширениемПослеОтветаНаВопросПовторить (БСП)

ЗакончитьРедактированиеБезРасширенияПослеОтветаНаВопросПовторить (БСП)

ОсвободитьФайлПослеОтветаНаВопросОтменаРедактирования (БСП)

ОсвободитьФайлыПоСсылкамПослеОтветаНаВопросОтменитьРедактирование (БСП)

СохранитьИзмененияФайлаСРасширениемПослеОтветаНаВопросОсвободитьФайл (БСП)

ЗакончитьРедактированиеСРасширениемПослеПомещенияФайлаНаСервер (БСП)

ЗакончитьРедактированиеБезРасширенияПослеПомещенияФайлаНаСервер (БСП)

ЗакончитьРедактированиеБезРасширенияПослеЗагрузкиФайла (БСП)

ЗакончитьРедактированиеБезРасширенияПослеШифрованияФайла (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз