АдресВОблачномСервисе (БСП)

Автор: 1С
ОбщийМодуль.РаботаСФайламиСлужебныйКлиентСервер
БСП

Адрес облачном сервисе. Синхронизация файлов

////////////////////////////////////////////////////////////////////////////////
// Синхронизация файлов

Функция АдресВОблачномСервисе(Сервис, Href) Экспорт
	
	АдресОбъекта = Href;
	
	Если Не ПустаяСтрока(Сервис) Тогда
		Если Сервис = "https://webdav.yandex.ru" Тогда
			АдресОбъекта = СтрЗаменить(Href, "https://webdav.yandex.ru", "https://disk.yandex.ru/client/disk");
		ИначеЕсли Сервис = "https://webdav.4shared.com" Тогда
			АдресОбъекта = "http://www.4shared.com/folder";
		ИначеЕсли Сервис = "https://dav.box.com/dav" Тогда
			АдресОбъекта = "https://app.box.com/files/0/";
		ИначеЕсли Сервис = "https://dav.dropdav.com" Тогда
			АдресОбъекта = "https://www.dropbox.com/home/";
		КонецЕсли;
	КонецЕсли;
	
	Возврат АдресОбъекта;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВнутреннийАдресМенеджераСервиса (БСП)

УстановитьВнутреннийАдресМенеджераСервиса (БСП)

АдресВебСервисаКонтактнойИнформации (БСП)

ОтправитьЗапросВМенеджерСервиса (БСП)

ИдентификаторыАдреса (БСП)

ПриСозданииЗапросаНаСменуПочты (БСП)

АдресЕАЭС (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз