РезультатОбработкиПакета (БСП)

Автор: 1С
ОбщийМодуль.РаботаВБезопасномРежимеСлужебныйВМоделиСервиса
БСП

Результат обработки пакета.

Функция РезультатОбработкиПакета(Знач ИдентификаторПакета) Экспорт
	
	Если ОбщегоНазначения.РазделениеВключено() Тогда
		Регистр = РегистрыСведений.ПрименениеРазрешенийНаИспользованиеВнешнихРесурсовОбластейДанных;
	Иначе
		Регистр = РегистрыСведений.ПрименениеРазрешенийНаИспользованиеВнешнихРесурсовВМоделиСервиса;
	КонецЕсли;
	
	Менеджер = Регистр.СоздатьМенеджерЗаписи();
	Менеджер.ИдентификаторПакета = Новый УникальныйИдентификатор();
	Менеджер.Прочитать();
	
	Если Менеджер.Выбран() Тогда
		
		Возврат Менеджер.Результат;
		
	Иначе
		
		ВызватьИсключение СтрШаблон(
			НСтр("ru = 'Не найден пакет запросов %1'"), ИдентификаторПакета);
		
	КонецЕсли;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьРезультатОбработкиПакета (БСП)

РезультатОбработкаРасшифровкиЗавершение (БСП)

ИзвлечьФайлыПакета (БСП)

ВыполнитьКоманду (БСП)

ОбработкаВыбора (БСП)

Замеряет скорость выполнения запроса и получает его выгрузки

СловарьТиповРезультатовОбработкиЗапросов (БСП)

ВыполнитьКомандуИзФормыВнешнегоОбъекта (БСП)

TurboConf - расширение Конфигуратора 1С