РежимИсполненияВнешнегоМодуля (БСП)

Автор: 1С
ОбщийМодуль.РаботаВБезопасномРежимеВМоделиСервиса
БСП

Режим исполнения внешнего модуля. Возвращает режим исполнения внешнего модуля в модели сервиса.

// Возвращает режим исполнения внешнего модуля в модели сервиса.
//
// Параметры:
//  ВнешнийМодуль - ЛюбаяСсылка,
//
// Возвращаемое значение - Строка - режим исполнения внешнего модуля.
//
Функция РежимИсполненияВнешнегоМодуля(Знач ВнешнийМодуль) Экспорт
	
	Если ОбщегоНазначения.РазделениеВключено() Тогда
		
		Ключ = РаботаВБезопасномРежимеСлужебныйВМоделиСервиса.КлючРегистраПоСсылке(ВнешнийМодуль);
		
		Если ОбщегоНазначения.ДоступноИспользованиеРазделенныхДанных() Тогда
			
			Режим = РегистрыСведений.РежимыПодключенияВнешнихМодулейОбластейДанных.РежимИсполненияВнешнегоМодуля(
				Ключ.Тип, Ключ.Идентификатор);
			
			Если Режим = Неопределено Тогда
				
				Режим = РегистрыСведений.РежимыПодключенияВнешнихМодулейВМоделиСервиса.РежимИсполненияВнешнегоМодуля(
					Ключ.Тип, Ключ.Идентификатор);
				
				Возврат Режим;
				
			Иначе
				
				Возврат Режим;
				
			КонецЕсли;
			
		Иначе
			
			Режим = РегистрыСведений.РежимыПодключенияВнешнихМодулейВМоделиСервиса.РежимИсполненияВнешнегоМодуля(
				Ключ.Тип, Ключ.Идентификатор);
			
			Возврат Режим;
			
		КонецЕсли;
		
	Иначе
		ВызватьИсключение НСтр("ru = 'Функция не предназначена для вызова в информационной базе, в которой выключено разделение по областям данных!'");
	КонецЕсли;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

РежимПодключенияВнешнегоМодуля (БСП)

КонтейнерыВнешнихМодулей (БСП)

ПиктограммаВнешнегоМодуля (БСП)

МенеджерВнешнегоМодуля (БСП)

ЗапросРазрешенийДляВнешнегоМодуля (БСП)

СообщениеУстановитьРежимИсполненияДополнительногоОтчетаИлиОбработкиВОбластиДанных (БСП)

СловарьКонтейнераВнешнегоМодуля (БСП)

СвойстваВнешнегоМодуля (БСП)

TurboConf 6 - расширение Конфигуратора 1С