ФормаОтчетаОбработкаВыбора (БСП)

Автор: 1С
ОбщийМодуль.РассылкаОтчетовКлиент
БСП

Форма отчета обработка выбора. Обработчик выбора формы отчета.

// Обработчик выбора формы отчета.
//
// Параметры:
//   Форма             - ФормаКлиентскогоПриложения - Форма отчета.
//   ВыбранноеЗначение - Произвольный     - Результат выбора в подчиненной форме.
//   ИсточникВыбора    - ФормаКлиентскогоПриложения - Форма, где осуществлен выбор.
//   Результат         - Булево           - Истина, если результат выбора обработан.
//
// Места использования:
//   ОбщаяФорма.ФормаОтчета.ОбработкаВыбора().
//
Процедура ФормаОтчетаОбработкаВыбора(Форма, ВыбранноеЗначение, ИсточникВыбора, Результат) Экспорт
	
	Если Результат = Истина Тогда
		Возврат;
	КонецЕсли;
	
	Если ТипЗнч(ВыбранноеЗначение) = Тип("СправочникСсылка.РассылкиОтчетов") Тогда
		
		ОткрытьРассылкуИзФормыОтчета(Форма, ВыбранноеЗначение);
		
		Результат = Истина;
		
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ФормаОбработкаВыбора (БСП)

ОбработкаВыбораТабличногоДокумента (БСП)

ОбработкаВыбора (БСП)

Программная обработка расшифровки отчета на СКД на обычных формах

ОткрытьВнешнююОбработкуИлиОтчет (БСП)

ОбработкаВыбораДополненияВыгрузки (БСП)

ФормаОтчетаОбработкаРасшифровки (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз