ПолучитьСвойстваФоновогоЗадания (БСП)

Автор: 1С
ОбщийМодуль.РегламентныеЗаданияСлужебный
БСП

Получить свойства фонового задания. Возвращает свойства ФоновогоЗадания по строке уникального идентификатора.

// Возвращает свойства ФоновогоЗадания по строке уникального идентификатора.
//
// Параметры:
//  Идентификатор - Строка - уникального идентификатора ФоновогоЗадания.
//  ИменаСвойств  - Строка, если заполнено, возвращается структура с указанными свойствами.
// 
// Возвращаемое значение:
//  СтрокаТаблицыЗначений, Структура - свойства ФоновогоЗадания.
//
Функция ПолучитьСвойстваФоновогоЗадания(Идентификатор, ИменаСвойств = "") Экспорт
	
	ВызватьИсключениеЕслиНетПраваАдминистрирования();
	УстановитьПривилегированныйРежим(Истина);
	
	Отбор = Новый Структура("Идентификатор", Идентификатор);
	ТаблицаСвойствФоновыхЗаданий = СвойстваФоновыхЗаданий(Отбор);
	
	Если ТаблицаСвойствФоновыхЗаданий.Количество() > 0 Тогда
		Если ЗначениеЗаполнено(ИменаСвойств) Тогда
			Результат = Новый Структура(ИменаСвойств);
			ЗаполнитьЗначенияСвойств(Результат, ТаблицаСвойствФоновыхЗаданий[0]);
		Иначе
			Результат = ТаблицаСвойствФоновыхЗаданий[0];
		КонецЕсли;
	Иначе
		Результат = Неопределено;
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СвойстваФоновыхЗаданий (БСП)

ЗаполнитьТаблицуСвойствФоновыхЗаданийВФоне (БСП)

ЗапуститьФоновоеЗадание (БСП)

ФоновоеЗаданиеЗагрузкиКлассификатораАдресов (БСП)

ФоновоеЗаданиеОчисткиКлассификатораАдресов (БСП)

ЗапуститьФоновоеЗаданиеСКонтекстомКлиента (БСП)

ОтменитьФоновоеЗадание (БСП)

ЗаданиеВыполнено (БСП)

СостояниеЗадания (БСП)

1С Менеджер конфигураций